Zertifikatsfehler NET::ERR_CERT_INVALID im Chrome Browser zu TESTZWECKEN umgehen

Um den Zertifikatsfehler NET::ERR_CERT_INVALID im Chrome Browser zu TESTZWECKEN zu umgehen, gibt es zwei Möglichkeiten.

Beim Erscheinen der entsprechenden Fehlerseite im Browser

  • im einfachen Fall auf „Erweitert“ und wenn dort vorhanden „Weiter zu … (unsicher)“ wählen“ oder
  • Direkt im Browserfenster „thisisunsafe“ tippen.

Beides unbedingt nur machen, wenn der Seite wirklich vertraut wird!

Embedded MariaDB4j unable to load openssl lib 1.0.0 (Mac OS Catalina)

On my Mac (Mac OS Catalina 10.15.3), after a `brew update & brew upgrade` the openssl lib was updated from 1.0 to 1.1.

Sadly, the embedded MariaDB(j) I‘m using for Java Application UnitTests seems currently not to be compatible with opelssl 1.1.

Caused by: ch.vorburger.exec.ManagedProcessException: Program [/.../MariaDB4j/base/bin/mysql_install_db, ...) failed, exitValue=1, last 100 lines of console:
dyld: Library not loaded: /usr/local/opt/openssl/lib/libssl.1.0.0.dylib
Referenced from: /private/var/folders/ws/b6yxxmzj3hb20lkqndwws27r0000gp/T/MariaDB4j/base/bin/my_print_defaults
Reason: image not found

A similar issue reported here: https://github.com/vorburger/MariaDB4j/issues/48 and more specific in a comment from January 19th https://github.com/vorburger/MariaDB4j/issues/48#issuecomment-573946677

My (temporary) solution was to switch openssl back to lastest 1.0:
$ brew switch openssl 1.0.2t
Cleaning /usr/local/Cellar/openssl/1.0.2t
Opt link created for /usr/local/Cellar/openssl/1.0.2t